Configuration de la 3G

Accueil Forums Entraidez-vous Configuration de la 3G

Mots-clés : ,

Ce sujet a 5 réponses, 3 participants et a été mis à jour par  Sthocs, il y a 5 ans et 5 mois.

6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #3837

    plaristote
    Participant

    Bonjour,

    Depuis réception de mon téléphone, à l’époque de la 1.0.0.5 et jusqwu’à la dernière version stable, je n’ai pas accès aux réseaux mobile.
    Ou plutôt, je n’y ai accès que lors du premier lancement du service connman. Ce qui signifie que chaque fois que mon téléphone reboot, pour faire fonctionner la 3G, je dois réinitialiser le téléphone (donc soit je suis bloqué en 1.0.0.5, à paniquer dès que la batterie est presque vide, soit sans internet mobile).

    Si vous avez une âme généreuse, vous pouvez m’aider très facilement.
    Etant donné qu’il n’y a aucune documentation disponible sur le sujet, j’ai besoin de voir comment sont fichus les fichiers de configurations chez quelqu’un chez qui l’internet mobile fonctionne. Avec un peu de chance, ça expliquera pourquoi est-ce que ça ne fonctionne pas chez moi.

    Les fichiers intéressants sont les suivants:
    /etc/connman/main.conf
    /var/lib/connman/settings
    /var/lib/connman/cellular_[un-hash-relatif-a-votre-telephone]_context1/settings

    Seul le dernier des trois fichiers contient des informations potentiellement sensible (IPV4.local_address, et IPv4.gateway).

    Est-ce que quelqu’un pourrait me montrer à quoi ces fichiers ressemblent chez lui ?

    #3878

    TellienInTouch
    Participant

    Déjà juste pour savoir, tu es chez quel opérateur et est ce que tes paramètres se sont configurés automatiquement ou l’as-tu fait manuellement?

    #3898

    plaristote
    Participant

    L’opérateur, c’est la poste mobile (réseau SFR).
    Les paramètres ne sont pas configuré correctement out of the box.
    Corriger les paramètres permet de se connecter en 3G uniquement si le service connman n’a jamais redémarré.

    Rebooter, ou lancer ‘systemctl restart connman.service’ fera disparaître le service cellular de connman. L’icône Mobile Data se grisera (comme quand la carte SIM n’est pas dans le téléphone), mais l’indicateur de signal 3G continue d’être présent sur l’homescreen.

    Aucune manipulation (rebooter, retirer la batterie, ré-insérer la carte SIM, supprimer les fichiers de configurations existants, ou combinaison de tout ça) ne fait réaparaître la 3G.
    Toutefois, réinitialiser le device to factory permet d’obtenir la 3G à nouveau (et ça disparaîtra à nouveau dès que connman rechargera sa conf).

    Pour la petite histoire, le device est arrivé comme cela. Ce problème était présent avant mon premier reset to factory, ou même ma première installation des outils de développeurs. Rien n’a changé entre la 1.0.0.5 et la 1.0.4.x.

    #3908

    TellienInTouch
    Participant

    Est-ce que tu pourrais installer l’application Radio Switch, disponible sur openrepos, elle permet de basculer en 2G pure, 2G/3G ou 4G pure.
    Cela permettrait de réaliser des tests supplémentaires pour comprendre d’où cela peut venir car tel que tu le décris, je pencherai peut-être pour un problème sur le module radio, même si cela semble fonctionner quand même en version 1.0.0.5

    #3909

    plaristote
    Participant

    C’est fait !

    La 4G a un statut offline, ce qui est de toute façon normal vu que je n’ai pas d’abonnement 4G.

    J’ai du signal en 3G et 2G, on y voit:
    Operator: La poste mobile
    Network: GSM
    Signal: -53dBm
    Status: home

    Ca confirme que le module radio fonctionne du coup j’imagine.

    #3932

    Sthocs
    Participant

    As-tu essayé avec un autre opérateur quand même ?

    /etc/connman/main.conf:

    [General]

    FallbackTimeservers = 0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org,3.pool.ntp.org
    StartSession = true
    NetworkInterfaceBlacklist = p2p,usb,rndis,rmnet
    SingleConnectedTechnology = false
    Ipv4StatusUrl = http://ipv4.jolla.com/online/status.html
    Ipv6StatusUrl = http://ipv6.jolla.com/online/status.html

    /var/lib/connman/settings:

    [Cellular]
    Enable=true
    Tethering=false

    [global]
    OfflineMode=false
    TimeUpdates=auto
    TimezoneUpdates=auto

    [Bluetooth]
    Enable=false
    Tethering=false

    [WiFi]
    Enable=true
    Tethering=false

    /var/lib/connman/cellular_[un-hash-relatif-a-votre-telephone]_context1/settings:

    [cellular_[un-hash-relatif-a-votre-telephone]_context1]
    Name=Free
    Favorite=true
    AutoConnect=false
    Modified=2014-04-10T12:05:06.215927Z
    IPv4.method=fixed
    IPv4.netmask_prefixlen=24
    IPv4.local_address=
    IPv4.gateway=
    IPv6.method=auto
    IPv6.privacy=disabled

6 sujets de 1 à 6 (sur un total de 6)

Vous devez être connecté pour répondre à ce sujet.